Problème de connection entre ma carte graphique et mes GPU

  • -

    Bonjour tout le monde!

    J’ai un grand problème avec mon miner.

    Voici mon setup:
    4 GPU r9 280x (driver version: 15.12)
    Mobo z270a-pro bios version:1.20 (7A71v12)
    4 risers
    PSU 1300 watts gold
    4 gig de ram
    SSD 120 GIG

    Je fais le tuto proposé par MSI : https://www.msi.com/blog/Mining_Intel_Motherboard_Go_with_MSI_100_200_Series_Motherboard

    Rendu à l’étape de fermer le miner et de brancher la 2e, 3e et la 4e GPU (redémarrage entre chaque GPU), mon miner commence a avoir de la misère a reconnaître les GPU.

    Auriez-vous une idée de pourquoi ma MOBO de réussi pas a reconnaitre mes GPU facilement?

    Merci de votre aide, ça fait 1 mois que je ne suis pas capable de les connecter. 😞

  • -

    hello

    y a un truc que je comprend pas dans ton explication :
    Tu dis que ton miner a du mal à reconnaitre les GPU et ensuite tu parles de la carte mère. Donc à partir de quel moment tes GPU ne sont ils pas reconnus ? Par la cm ou ton logiciel de minage ? Est-ce que tes cartes réagissent lorsque tu boot ton rig ?

    En ce qui concerne le bios, les Z270-A Pro sont au 1.4

    Dans le bios, quand tu es là :
    Settings\Advanced\PCI Subsystem Settings
    Change le Max Link speed de Auto à Gen2 et sur la fonction en dessous tu sélectionnes 64-bit.

    Enfin la fonction 4G decoding n’est nécessaire que si l’on a + de 4 GPU sur la carte (par contre je ne sais pas si ça a un effet de l’activer avec moins, j’ai jamais essayé).

  • -

    Merci de ta réponse François!

    Ce que je fais:

    Windows 10 Pro est installé

    1. Je change dans le BIOS pour que mon écran soit sur le GPU intéfré.

    2. Je ferme l’ordi

    3. Je connecte la premier GPU1

    4. J’installe le driver 15.12 (je redémarre) (j’essaye d’ouvrir l’application Radeon setting sans succès il me dit que le driver n’existe pas ou mal installer pourtant je le vois bien dans mes drivers)

    5. Je referme l’ordinateur, j’ai changé option 4G (J’ai aussi testé PEG0 à GEN2)

    6. Je referme l’ordinateur, je le débranche je retire tout l’électricité dans l’ordinateur en tenant le bouton power

    7. J’ajoute le GPU2

    8. Je démarre l’ordinateur et la je commences à avoir des problèmes, des fois le GPU2 est là, des fois il me dit que le driver ne fonctionne pas.

    9. Si la GPU2 est la et a l’air de fonctionner, je refait tout à partir de 6 pour le GPU3 et rendu la je ne suis jamais capable d’avoir 3 GPU dans le gestionnaire de pilote

    oui les GPU réagisent (les fans tournent) et 64 bit? je ne suis pas sur d’avoir cette option je vais remettre le bios a v1.4 alors.

    Merci de votre aide

  • -

    Tu as essayé un petit coup de DDU et réinstallation du driver ?
    Pour le pilote, essaie plutôt le Driver blockchain :
    http://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-Crimson-ReLive-Edition-Beta-for-Blockchain-Compute-Release-Notes.aspx

  • -

    Oui j’ai utilisé DDU je vais essayer l’autre driver alors 🙂 je vous donne des nouvelles demain.

    Merci 🙂

    ps. j’ai que les options suivant pour le BIOS: PEG0, PCI Latency Timer et Above 4G memory

  • -

    Bonjour et bonne année!

    J’ai testé ce que tu m’as parlé voici les étapes que j’ai fait:

    1. Remise de la configuration initial du BIOS

    2. Mise à jour du BIOS avec la version 1.40

    3. Go en mode sans échec, utilise DDU et redémarrage

    4. Ouveture du BIOS pour mettre l’option IGD

    5. Fermeture de l’ordinateur et ajout de la premier GPU01

    6. Ouverture du BIOS pour changer PEG0 à GEN2 et le clock speed a 96

    7. Ouverture de l’ordinateur et ajout du driver beta amd pour le blockchain

    8. Redémarrage (je vois le pilote dans le device manager et je suis capable d’aller dans l’apps AMD setting)

    9. Fermer l’ordinateur et ajout de GPU02

    10. ouverture de l’ordinateur va voir dans les pilotes je vois VGA compatible et je vais mettre a jour le driver et la je vois les 2 GPU avec les bons driver

    11. Redémarre l’ordinateur et quand j’essaye d’ouvrir l’apps AMD setting l’ordinateur plante.

    12. Je ferme l’ordinateur et j’ajoute la GPU3 et ça ne fonctionne plus.

    GPU01: shapphire vapor-x
    GPU02: shapphire vapor-x
    GPU03: Asus R9 280x DirectCU II

    Avez vous des idées?

    Merci de votre aide!

  • -

    Déjà met le clock speed à 64, 96 est inutile dans le cas présent.
    Pour ma part quand j’installe un pilote AMD, je fais une installation minimum (juste le pilote d’affichage) car j’utilise des logiciels tiers pour les réglages et monitoring. Donc j’avoue ne pas avoir rencontré ton problème

    Quand tu installes les GPU à partir du second, le pilote s’installe tout seul mais ça prend un peu de temps pour que Windows détecte et mette à jour. Donc ne fais rien à ce moment là.

  • -

    Bon j’ai fait comme vous m’avez dit. J’ai mis 64, j’ai été en mode sans echec pour delete le pilote pour recommencer et juste installer le pilote d’affichage et rendu au 3e, mon rig a l’air de mal le prendre(bug et a l’air de redémarrer sans installer le pilote)

    update: je viens de partir claymore avec 2 GPU et il me semble qu’il fonctionne bien sans overcloaking

    update2: quand je rajoutes la 3e tout commence a planter, avori des bleuscreen et la je viens de retirer la 3e et je recois encore des bleuscreen. je ne sais plus quoi faire

  • -

    Tu les mets toujours dans le même ordre ? les deux Sapphire puis l’Asus ?
    Si oui, tente l’Asus en premier pour voir si c’est elle qui bloque.

    Si non, tu refais le même processus sans installer le pilote AMD. Je m’explique. Tu plug une carte tu démarres, tu vérifies qu’elle est listée sur Windows. Si oui, tu éteins, tu plug la second tu boot et tu regardes si les deux cartes sont listées dans Windows. Pareil pour la troisième.
    Si les trois cartes sont reconnues sans soucis, à ce moment là, installe le pilote.
    J’avais procédé ainsi à un moment où je pensais qu’une de mes Vega était défectueuse et l’installation s’est finalement bien passée.

  • -

    Merci de ta réponse! Je viens de mettre GPU03(ASUS) dans PCI01 et GPU01 dans PCI02 ça fonctionne normalement. je l’ai laissé tourné un 5-10 mins et il a l’air de bien fonctionner sans planter.

    Maintenant je ferme le RIG, je déconnecte le courant, j’ajoute GPU02, je remets le courant et j’ouvre le RIG.

    Ensuite j’ouvre le manager de device, on peut voir les 3 GPU avec le pilote d’installer. Quand je start claymore, je vois les 3 GPU mais j’ai un Thread stuck in drevice.

    As-tu un idée?

    Merci de ton aide!

  • -

    Le BSOD “Thread stuck in device driver” intervient dans plusieurs cas :

    • mauvais réglages des paramètres de consommation (il faut le mettre en performance élevée)
    • riser défectueux
    • carte qui chauffe trop
    • carte trop overclockée
    • Pilote corrompu
  • -

    Bon j’ai mis les performance a élevé, j’ordinateur n’as pas gelé de la nuit sur 2 GPU.

    Voici le topo

    J’ai GPU0 = Asus, GPU1 VAPOR et j’ai essayé de mettre soit ma 2e VAPOR ou ma 2e ASUS comme GPU03 mais encore la, soi que le hashage ne fonctionne pas sur GPU02 quand je le démarre Claymore, soi que l’ordinateur a de la misère a ouvrir par la suite avec 3 GPU.

  • -

    Crossfire désactivé dans la base de registre ?
    Ton problème ressemble à un problème d’alimentation trop just mais avec 1300W ça devrait passer large, je comprends pas.

  • -

    @invité a dit dans Problème de connection entre ma carte graphique et mes GPU :

    Crossfire désactivé dans la base de registre ?

    hmmm? je cherche sur internet comment le déactiver

  • -

    regedit
    tu vas dans ce répertoire :
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class{4D36E968-E325-11CE-BFC1-08002BE10318}

    Là seront listées tes cartes graphiques. Si tu as un iGPU, ce sera le 0000.
    Pour chacune de tes cartes ATI, tu ouvres son répertoire, tu cherche EnableCrossfire, tu double-cliques, et tu changes la valeur 1 par 0.
    Pendant que tu es là, tu fais pareil pour la valeur EnableUlps qui est juste en dessous.

  • -

    @invité a dit dans Problème de connection entre ma carte graphique et mes GPU :

    Pendant que tu es là, tu fais pareil pour la valeur EnableUlps qui est juste en dessous.

    en fesant ça j’ai des bon résultat(Claymore fonctionne) avec 3 GPU, je viens d’installer la 4e GPU et j’essayer d’ouvrir le RIG

  • -

    Désolé du double post,

    Comme j’ai dit plus haut, j’ai réussi a faire fonctionner claymore avec 3 GPU, j’ai voulu faire mon dure et mettre la 4e GPU et j’ai jamais réussi a faire fonction 3 ou 4 GPU. Quand je suis a 3 GPU il a de la misère à faire le OPENCL de la GPU03 et Claymore fini par geler. As-tu un idée?

  • -

    A part un problème avec un pilote corrompu, je vois pas

  • -

    je vais essayer de reprendre le dernier pilote de AMD et/ou le 15.12 mais bon c’est vraiment weird, je ne suis pas cpable de trouver une stabilité.

  • -

    Petite question, quelque soit le montage de tes cartes lorsque tu branches plus de 2GPU ça plante c’est ca?
    Si oui pourrais tu me dire si tu utilises les mêmes risers sur les mêmes CG (en gros est ce que tu déconnectes les risers des CG pour les rebranchers ou les laisses tu branchers sur le port PCI-EX de ta CG quand tu fais tes manips) ?
    Si ce n’est pas le cas, au niveau de ton alimentation utilises tu les connectiques VGA dans l’ordre ? Par exemple tu prends le VGA1 pour la CG1 puis le VGA2 pour la CG2 etc … C’est pour savoir si quand tu arrives au VGA3 ou VGA4, ça plante ou tu utilises le VGA1 sur la CG4. Désolé j’ai essayé d’être clair mais nuit compliquée 😅

Log in to reply