Optimiser Eth avec CUDA



  • Hello,

    Faut bien se lancer un jour !

    Par curiosité, je me suis lancé dans du minage d’Eth, en utilisant le Dwarfpool et la méthode ici :
    http://www.ethereum-france.com/comment-miner-de-lether-eth-windows/
    Du coup, comme j’ai une Nvidia GTX660 et sur un autre PC une GTX 970, je passe par ethminer-cuda (dans le zip du programme dont le lien est dans le tuto pour miner sur dwarfpool).

    Après avoir configuré le proxy, me suis créé deux petits .bat pour lancer mon bordel :
    Le premier pour quand je bosse en parallèle (bureautique, pas trop besoin du GPU) :
    start /min ethminer.exe --farm-recheck 200 -F http://127.0.0.1:8080/OkkohWork -U --gpu-batch-size 18 --gpu-mining-buffers 2 --gpu-workgroup-size 128
    Si je mets plus, ca n’est pas fluide d’utiliser l’ordi. J’obtiens un hashrate d’environ 12.

    Le second quand je suis pas à l’ordi :
    setx GPU_FORCE_64BIT_PTR 0
    setx GPU_MAX_HEAP_SIZE 100
    setx GPU_USE_SYNC_OBJECTS 1
    setx GPU_MAX_ALLOC_PERCENT 100
    start /min ethminer.exe --farm-recheck 200 -F http://127.0.0.1:8080/OkkohWork -U --gpu-batch-size 20 --gpu-mining-buffers 4 --gpu-workgroup-size 256 --high-cpu-load
    Lorsque j’arrête, je redémarre l’ordi. Mais celui-ci je l’ai pas encore testé.

    Finalement, ca a l’air de pas trop mal fonctionner, mais j’ai fait ca au feeling avec ce que j’ai pu trouver, je n’arrive pas à savoir si tout ca est bien optimisé car il semble difficile de trouver comment optimiser les choses.

    Des avis, des remarques par hasard ?



  • Sans surprises, ma seconde config marche vraiment mieux que la première pour le hashrate, par contre je ne peux plus rien faire avec l’ordi.

    Par contre, bizarrement, avec les mêmes options, ma GTX970 (Win10) mine moins vite que ma GTX660 (Win7), quels que soient les paramètres que j’utilise. Est-ce dû à l’OS ? Au soft ? Je vais essayer avec AlethOne pour voir…


  • Etherian

    Salut,

    Effectivement j’ai vu un post de Genoil (créateur du eth-miner CUDA) dans lequel il indique que Windows 10 gére les GPU d’une manière différente par rapport à Windows 7/8.1 ce qui entraîne une baisse de hashrate conséquente.



  • @Palladium tu as un lien vers ce post ? cela pourrait aider à comprendre le problème :)


  • Etherian

    @ffmad Oui, ça se passe ici :smiley: : https://forum.ethereum.org/discussion/comment/24630/#Comment_24630

    "The real problem is in Win10 / WDDM 2.0. Its new GPU memory virtualization method does not play nicely with ethminer on Nvidia. Simplest solution is using win 7 or 8 or Linux. Others have succeeded with downgraded drivers (347 series). Perhaps you could also try installing latest win7/8/vista drivers instead of win10 drivers. Not sure if that will work. "

    D’ailleurs la totalité de la file est très intéressante pour ceux qui minent avec des GPU Nvidia.



  • Finalement après de nombreuses recherches, je suis repassé sur W7, trop de galères sous W10, de toute façon l’OS n’est pas suffisamment abouti à mon goût. J’en ai profité pour écrire un tuto ici : http://www.ethereum-france.com/comment-miner-de-lether-eth-sous-windows-version-complete/



  • okkoh quand je test ta commande ca marche pas .

    tu peux m’aider stp ? merci