Xmr-stak moins performant que Claymore



  • Bonjour à tous,

    Je minais jusqu’à maintenant du Monero avec Claymore Cryptonote. Config :

    GPU : 1x RX560, 1x RX570, 1x RX580
    CPU : Intel® Pentium® CPU G4560 @ 3.50GHz
    OS : HiveOS

    Hashrate et consommation sur Claymore : 1630 H/s pour 230W

    Je voudrais passer sur Xmr-Stak pour bénéficier du minage CPU et parce que j’ai rencontré un problème avec Claymore.
    Mon Hashrate des GPU a chuté à 1410 H/s pour 220W. J’ai essayé de modifier des paramètres du miner mais rien ne change…

    Pourquoi cette différence ?
    Y-a-t-il une configuration à appliquer sur Xmr-Stak pour augmenter le hashrate ?

    Je sais que le hashrate peut changer d’un miner à l’autre selon son optimisation mais là je trouve quand-même qu’elle est importante…

    Merci d’avance pour votre aide.



  • Je n’ai pas la réponse mais je constate la même baisse de performance que toi. Ce n’est effectivement pas négligeable !



  • @tr474 Marrant suis aussi entrain de le bidouiller 🙂

    XMR-Stack nécessite beaucoup plus de configuration que claymore-x.
    Il faut mettre 2 thread par GPU et régler l’intensity.



  • @impassenet Génial, merci pour l’astuce!



  • @impassenet Merci beaucoup !
    Avec un peu de temps et des recherches sur Internet j’ai même réussi à dépasser le hashrate de Claymore 😃



  • @sygmacrypt Tu peux partager ta configuration?



  • Of course 😉

    Ma config pour :
    GPU0 = RX580 Sapphire Nitro+ 4 GB Ellesmere
    GPU1 = RX570 XFX 4 GB Ellesmere
    GPU2= RX560 Sapphire Pulse 4 GB Baffin

    “gpu_threads_conf” :
    [
    // gpu: Ellesmere memory:3135
    // compute units: 36
    { “index” : 0, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2, “comp_mode” : true },
    { “index” : 0, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2, “comp_mode” : true },
    // gpu: Ellesmere memory:3135
    // compute units: 32
    { “index” : 1, “intensity” : 768, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2, “comp_mode” : true },
    { “index” : 1, “intensity” : 768, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2, “comp_mode” : true },
    // gpu: Baffin memory:3135
    // compute units: 16
    { “index” : 2, “intensity” : 896, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2, “comp_mode” : true },
    { “index” : 2, “intensity” : 896, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2, “comp_mode” : true },
    ],
    “platform_index” : 0,



  • Résultats dans xmr-stak 😉 :

    0_1537985671079_Capture du 2018-09-26 20-13-49.png

    Ca ne se joue pas à grand chose par rapport à Claymore (même si j’ai réussi à atteindre 1670 H/s avant un reboot) mais en ajoutant le CPU ça devient intéressant 😃



  • @sygmacrypt Je sais pas pkoi je fait pareil que toi et j’ai une erreur à la con.

    0_1538137271945_a39d69ff-acf6-400c-98eb-9dab2339484c-image.png



  • Je me sens moins seul, j’ai exactement la même erreur 🙂



  • @impassenet @Tr474 N’utiliser pas le fork indeedminers 😉

    J’ai pas de soucis non plus, super stable depuis 3 jours. Par contre ça fonctionne pas bien sur tout les algo, besoin d’ajustement je pense.

    “gpu_threads_conf” : [
    // gpu: Ellesmere memory:3135
    // compute units: 36
    { “index” : 0, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2, “comp_mode” : true },
    { “index” : 0, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2, “comp_mode” : true },

    // gpu: Ellesmere memory:3135
    // compute units: 36
    { “index” : 1, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2, “comp_mode” : true },
    { “index” : 1, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2, “comp_mode” : true },

    // gpu: Ellesmere memory:3135
    // compute units: 36
    { “index” : 2, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2, “comp_mode” : true },
    { “index” : 2, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2, “comp_mode” : true },

    // gpu: Ellesmere memory:3135
    // compute units: 36
    { “index” : 3, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2, “comp_mode” : true },
    { “index” : 3, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2, “comp_mode” : true },
    ],

    “platform_index” : 0,



  • Effectivement, je n’utilise pas de fork du miner.
    Ignorant la différence, j’ai laissé la conf par défaut.

    J’ai néanmoins un problème avec cette conf de GPU ! Ma RX560 s’arrête constamment après environ 1h de minage. Ma conso réelle (indiquée sur le boitier powercost control) descend d’environ 10-15 W et j’ai des (na) à la 3eme ligne (correspondant aux 2 threads de la RX560) du hasrate report. En redémarrant seulement le miner, ce dernier ne se lance pas et m’indique l’erreur “HTTP deamon failed to start”. En rebootant le rig, le minage reprend normalement mais après 1h, la RX560 s’arrête à nouveau.

    J’ai essayé de modifier les paramètres d’OC mais rien ne change. Sur Claymore, ce problème apparaît très rarement avec le message “Claymore reboot : GPU2 hangs in OpenCL”

    Je pense que le problème doit provenir de la GPU et dans ma conf d’OC malgré plusieurs profils différents.
    Je suis finalement retourné sur Claymore car ce problème se produit rarement, le temps que je trouve une explication et une résolution à cette anomalie.



  • perso j’arrive pas a trouver comment booster mes 1050ti sur xmr stak je tourne a ±100hs sur monerov7.

    tu aurais pas un bon lien que je comprene quoi faire ?



  • @impassenet Je débute également sur XMR stak, pour du LOKI, si quelqu’un peut me renseigner sur le wallet à rentrer, sur Cryptopia il me met deux info pour le déposit, lequel rentrer sur XMR stak ? Le Payment id ou le Cryptopia Loki address ?0_1539031196958_Screenshot_20181008-223247_TeamViewer.jpg



  • @le_choux Peux-tu développer ce que tu veux dire par là ? Je suis globalement débutant et le “fork indeedminers” je n’ai aucune idée de ce que c’est 😊



  • @tr474

    Sous HiveOS tu as le choix entre XMR-Stak master, XMR-Stak fireice, XMR-Stak indeedminers.

    Il faut choisir celui par défaut.

    0_1539117778887_9919dcbb-47a5-43c9-8968-030e128a11f5-image.png


Se connecter pour répondre
 

Il semble que votre connexion ait été perdue, veuillez patienter pendant que nous vous re-connectons.